Error Enabling Flyspell Mode

Emacs in Fedora 22 insist on using aspell as its default dictionary. Fedora when installed with locale other than en-US doesn’t seem to install aspell-en. This causes Flyspell mode to give following error.


The above error can be fixed by adding following to your ~/.emacs which is taken from Chen Bin‘s spell check set up blog post.

This doesn’t fully solve our problem. Starting Flyspell mode will give you following error.

To resolve this issue you can install aspell-en.x86_64 as follows.